Auto authorise auth permission request


#1

image

I am currently developing a webpage with SAFE API. Everytime the webpage runs, it will requires the user to accept the request auth permission as shown. When I reload the webpage at the second time it will just waiting and never show the permission request anymore until I restart the browser.

I’ve try to skip the window.safeApp.authorise part but it seems to be important to get the auth_uri. Is there any other way that user can always authorise automatically or at least show the request permission every time I reload so that I do not need to restart every time to see the updated code?


#2

Hey @JackTiew In the SAFE Authenticator, under Authorised Apps there is a small lock icon on the top left corner. This icon toggles automatic app re-authentication and it is disabled by default. Enabling that should help you out


#3

Should it be lock or unlock for the icon? Because I have tried for both but it still having the same problem…


#4

To auto-authorise apps, the icon should be unlocked.


#5

Unfortunately I allow to re-authenticate automatically but the authorise function is just waiting forever…


#6

What version of the browser are you using? Consider using the latest version. As an easy alternative you can try out this version of the beaker browser.


#7

I am using peruse browser v0.5.1


#8

@JackTiew, this seems similar to something we’ve seen this issue before with certain builds.

Can you please try the latest build here: https://github.com/joshuef/peruse/releases/tag/v0.5.3 and let us know how you get on!

If there are still issues, please let us know your system info too, thanks :+1:


#9

Yes this version of peruse works perfectly! Thank you so much!:laughing::laughing:


#10

Good news @JackTiew - Thanks @joshuef!

I’ll close this off now.


#11