Can anyone build Mock-Routing on Win?


#1

Been having lots of trouble, installed 10 Gigs of “prerequisites” and still nothing but errors.

Just trying to make this part work:
cargo build --release --features use-mock-routing

Now I’m at an error where it’s asking for a “gcc.exe” and I’ve tried Cygwin64, Mingw64 and so many things but nothing ever gives me anything called “gcc.exe” is there a way to get “gcc.exe” on windows?

I know @maidsafe is busy making the network etc but we have app devs needing this and windows is a major OS so it needs support please!


Mock-Routing again :P (Windows)
#2

Yea the guys are mad busy, but maybe I can help out. if you type gcc.exe --version it should give output, without that then it won’t work. I have not used win since 1994 but I think there are several command lines there. One for mingw, one for cmd and another for visual studio.

In the terminal you are in though you will first need gcc in your path for sure.

This may help https://facility9.com/2016/03/installing-rust-on-windows/


#3

Hey, I just installed this on Windows 10/64 and had no problem.

  • Go to this website and install MinGW. That shouldn’t give any problem.
  • Set your Windows path like the guy is doing here in this video. I directly linked to the right part in the video.

That’s all!

You should be able to check the version from whatever directory you’re in. That’s the reason you’ve been asked for GCC, the script wants to just start GCC and use it. If the path isn’t right the buildscript isn’t able to find that little executable.

Here’s the full video.

let me know if this works.

EDIT: If I remember well you want to use this version of Rust. Here’s the full list of files. Make sure to pick the GNU one :+1:.


#4

ok thx I went there and installed the overall program,

and marked these two and installing them. Those are correct right?


#5

Don’t know for sure, I just installed them all :yum:.


#6

hmm well ok I’ll try installing them all now this time instead


#7

thx guys it’s just their Vietnam meetup is today and I need to help because everyone uses windows. They want to show what SAFE Apps look like and make some new examples


#8

Have you set the path like the dude in the video??? You really need to, no matter what you install.

This is what you need to set in system variables:


#9

yep definitely, nothing

that screenshot was what I get after doing all that together

at least I see “gcc.exe” in that “C:/MinGW/bin” folder, which is nice

but still nothing working on cmd “gcc --version”


#10

I had trouble the first time. When you add the line in the path make sure to give an extra “enter”. Then the path to MinGW really gets added. After that choose the OK on all the different forms like you already did.The dude in the video is giving the extra enter as well, if you just choose OK it doesn’t work for some reason.

EDIT: Here’s the exact part in the video.


#11

ok I kind of hacked something together with this:

PATH=C:\MinGW\bin

so once I cd’ed into the folder, I typed that command above and gcc --version works so now I’m trying to compile mock-routing launcher

it only has to work this one time and that’s enough for me to give a binary to everyone :slight_smile:


#12

dang dang dang dang dang


#13

GCC working now? So this is new trouble with something :grin:?


#14

I guess, did you ever get it working? build mock-routing launcher successfully?


#15

No, not really tried very hard though as I know a lot of others have trouble as well. I once build my own Vault and the “old” browser without Authenticator. I’ll wait until the devs say: here’s the script, should work now.


#16

I think you are replacing your system path with only the single path entry for gcc. That’s not right, you need to add the mingw dir to your path not replace it.

Start the System Control Panel applet (Start - Settings - Control Panel - System).
Select the Advanced tab.
Click the Environment Variables button.
Under System Variables, select Path, then click Edit.

EDIT - Log in again before doing this as you probably have a screwed path right now :wink:


#17

Ok I think I got this sorted, I had the MinGW variable in the user variables part also, before fixing it just now. Also wasn’t clicking the “Path” one before

trying to compile again…

thx very much for the help wit hthis


#18

ugh, IDK it gave me the exact same error again as the black cmd screen i posted above

EDIT: Updated pic above, in previous post^


#19

Hmm now it gave me this new error. Progress! I think

This error message is shorter, so that’s good!

I don’t know what MSVC is


#20

Seems perhaps you chose the msvc build for rust and not the gcc one? If you use gcc it will probably be easier.