Clearing cache in peruse browser


#1

Is there any way to clear the cache in [latest peruse browser] https://github.com/joshuef/peruse/releases/tag/v0.5.1) just like safe browser have the option with hard reload (clear cache)?


#2

Not yet @JackTiew.

I’ve just added a github issue for that over here: https://github.com/joshuef/peruse/issues/79

:+1:


#3

If I modify a JavaScript or HTML file I’ve been using Ctrl-R from the browser console and that works.

I’ve also found that just clicking the reload toolbar button works.

This doesn’t clear the cache, but it does cause Peruse to reload the modified file, which is normally what is needed.


#4

I’ve tried that but not working…Are you using the version v0.5.1? Because the previous version is fine but I am unable to connect the network so I download the latest one and then it’s not working anymore…


#5

Earlier than 0.51 but I’m not sure the latest version I was using. Certainly it was OK with 0.41


#6

I’ve tried v 0.5.1 it’s not refreshing so I went back to v 0.4.1 and it has the same problem now. Restarting the pc doesn’t help as the web page is still showing the old version instead of my modified files. Even if I remove the files from the localhost, it still possible to load the web page. I am stuck in the progress and cannot further do more testing. Can anyone help me with this issue?


#7

I can’t solve it but I wonder if it is related to your OS (I’m using Debian Linux) or the Web server configuration (I assume you are using localhost). Or perhaps you have a cache manifest file - I think that can cause this behaviour.

Just a few thoughts. Good luck.


#8

I don’t think that is the web server configuration because i even turn off the localhost and it still showing the old web page. If it is the cache manifest file, how can I solve it? I’ve tried to reinstall few times the browser but it doesn’t clean the files…


#9

Try deleting or renaming any cache manifest file (I think it is called “cache.manifest”) or edit it to exclude the files you are working on.