Failed to append to Sequence: NetworkDataError

Are sequence appends currently supported in CLI? I’ve been getting this error for a while, using latest binaries.

paul@Vader:~$ safe seq store "element1"
Public Sequence stored at: "safe://hyryyyy3zcwnjrdse6gfhftddji5ej8k8cybp4z39qnhfregtmys7bcjxfynmy"
paul@Vader:~$ safe seq append "element2" "safe://hyryyyy3zcwnjrdse6gfhftddji5ej8k8cybp4z39qnhfregtmys7bcjxfynmy"
Error: NetDataError: Failed to append to Sequence: NetworkDataError(InvalidSignature)

Versions:

paul@Vader:~$ safe node update
Checking target-arch... x86_64-unknown-linux-musl
Checking current version... v0.28.2
Checking latest released version... v0.28.2
Update status: '0.28.2'!
paul@Vader:~$ safe auth update
Checking target-arch... x86_64-unknown-linux-musl
Checking current version... v0.1.1
Checking latest released version... v0.1.1
Setting execution permissions to installed binary '/home/paul/.safe/authd/sn_authd'...
Update status: `0.1.1`!
paul@Vader:~$ safe update
Checking target-arch... x86_64-unknown-linux-musl
Checking current version... v0.19.1
Checking latest released version... v0.19.1
Update status: `0.19.1`!

Thanks!

1 Like

That must be because you haven’t self-authorised the CLI with authd, so what happens now (temporarily until rewards is available) if the keypair was not assigned to CLI (the one stored at ~/.safe/cli/credentials) the sn_api/sn_client will create a random one and preload it with simulated-payout, but this will happen for every command you execute from CLI. Thus, first command when you create the Sequence is being owned by a different keypair than the one used when trying to append to that same Sequence.

In summary, this is temporary and once we have rewards enabled on the network you won’t be allowed to even create the Sequence without the CLI being authorised (i.e. having a keypair in the credentials file). So just try with making sure the CLI is self-authed before creating the Sequence and then it should be using the same keypair for all commands, that should do it…if not please shout!

2 Likes

That was it! It sounds like the error message will improve once the simulated-payout is gone.

I think I must have deleted my .safe directory at some point and just not realised the app wasn’t authorized. I tried wiping it again after allowing and I could repeat the error until I allowed the CLI app.

Mystery over! :slight_smile:

1 Like

Yes, we should improve the error eventually as you say.

You should be able to reproduce it by clearing the CLI’s keypair/credentials with $ safe auth clear

2 Likes