Getting 'Out of memory error' running an electron-compiled app on Ubuntu 16.04, after authorization

I am working on an electron safe app.
OS Version: Ubuntu 16.04
I am using, Safe Browser mock version, safe_browser-v0.2.1-linux-x64-mock with integrated safe authenticator.
After compiling and opening the electron app, (i tried authorization as given in web hosting manager application),
i do get authorization request on integrated safe authenticator in the safe_browser,

After I allow the request, application crashes and I get linux Out of Memory error.
Registering protocol handler: safe
Registering protocol handler: safe-auth
Wiring up Web API: safeApp
Wiring up Web API: safeCipherOpt
Wiring up Web API: safeImmutableData
Wiring up Web API: safeCrypto
Wiring up Web API: safeCryptoKeyPair
Wiring up Web API: safeCryptoSecEncKey
Wiring up Web API: safeCryptoPubEncKey
Wiring up Web API: safeCryptoSignKey
Wiring up Web API: safeMutableData
Wiring up Web API: safeMutableDataEntries
Wiring up Web API: safeMutableDataKeys
Wiring up Web API: safeMutableDataValues
Wiring up Web API: safeMutableDataMutation
Wiring up Web API: safeMutableDataPermissions
Wiring up Web API: safeMutableDataPermissionsSet
Wiring up Web API: safeNfs
Wiring up Web API: safeAuthenticator

[7569:0827/] Out of memory.
#0 0x000001e56c0e
#1 0x000001e6c90b
#2 0x000001e8857e
#3 0x00000170ff99 realloc
#4 0x7fe399c8ad0e
#5 0x7fe399c870d0
#6 0x7fe399cace5a
#7 0x7fe399c4aa5c
#8 0x7fe399b0413f
#9 0x7fe39a1d163b
#10 0x7fe399c4a3e8 decode_ipc_msg
#11 0x7fe3a7c6ee40 ffi_call_unix64
#12 0x7fe3a7c6e8ab ffi_call
#13 0x7fe3b0e1ac6b
#14 0x7fe3b0e254b6
#15 0x7fe3afc616ba start_thread
#16 0x7fe3a96ee3dd clone

Could somebody explain and help me to overcome this memory error.

Hi @sadeesh.r, that’s an old version now.
I recommend you pull the latest code from the browser’s master branch, and build it to use mock. You can do that by setting the environment variable NODE_ENV=dev and then run yarn run burnthemall. Yo may need to install yarn if you don’t have it.


@bochaco, Thank you, I will try it right away and update here.

it worked and no more linux memory error. Thank you. :pray: :sunglasses::+1::+1:


This topic was automatically closed after 60 days. New replies are no longer allowed.