How to build the SAFE Browser and upload a website with Mock-Vault


#21

What OS and version are you using?
If linux, can you post you relevant ~/.bash_history, please?


#22

Linux Mint 18.1. I’ll try to give you that later today, I should be working right now :wink:.
Not that I think it will differ from the instructions of @frabrunelle.


#23

OK thanks - I think the only difference between Mint and my Ubuntu 16.04.2 was some of the dependencies come as standard on Mint and some of the others on Ubuntu.
All minor and very sortable.
Whats bugging me is why the packaging failed ths last time with
npm run release:linux

when it seemed to work earlier.
That’s why I wanted to exactly replicate your bash_history.


#24

QUICK UPDATE:
I can get te SAFEbrowser to compile if I ignore the advice to skip Step 5.

THat is I do a
npm run rebuild
and then
npm run release:linux

completes succesfully.
Then I can run the browser with
./dist/linux-unpacked/SAFEBrowser

However when I try to run the Authenticator it seems to accept my (fake) token and allows me to enter and confirm secret and password Then hit ‘CONTINUE’ and I get thrown back to this…

Any clues @frabrunelle , anyone?


#26

At some point, I had also this error message.
I don’t know why, but maybe retrying will help (after graphical logout/login or reboot).
You probably didn’t do this, but don’t start the apps as another user then you’r logged in graphical (X). That didn’t work so well for me.

I’m able to correctly upload website + surf to it with Beaker.
Deleting file (MutableData?) or Upload Directory don’t work for me.
Pushing on the created service ‘url’ in the ‘SAFE Hosting Manager’ gives following output in the console:
gvfs-open: safe://<service>.<plubic id>/index.html: error opening location: The specified location is not supported

Here the commands I executed:

#installing node(.js)
#become root
sudo -i
cd /usr/local
wget https://nodejs.org/download/release/v6.5.0/node-v6.5.0-linux-x64.tar.xz
tar -xf node-v6.5.0-linux-x64.tar.xz --strip-components=1
#if you want to remove this node version afterwards (ignore errors):
#tar -tf node-v6.5.0-linux-x64.tar.xz --show-transformed --strip-components=1|xargs rm
#tar -tf node-v6.5.0-linux-x64.tar.xz --show-transformed --strip-components=1|xargs rmdir
#leave root!
exit
#check
node --version

#installing Rust
curl https://sh.rustup.rs -sSf | sh
source ~/.cargo/env 
rustup override set 1.16.0
#check
rustc --version

#safe_browser
git clone https://github.com/maidsafe/safe_browser.git
cd safe_browser && git checkout dev
npm install
npm run pack-authenticator
npm run rebuild
npm run release:linux
./dist/linux-unpacked/SAFEBrowser

#in new terminal: safe_hosting_manager
git clone https://github.com/maidsafe/safe_examples.git
cd safe_examples/web_hosting_manager && git checkout dev
#installing necessary packages
sudo apt-get install libsecret-1-dev
sudo apt-get install libgnome-keyring-dev
#sudo apt-get install node-gyp

#not necessary form me at second build (other user, after reboot)
#export PKG_CONFIG_PATH=/usr/lib/x86_64-linux-gnu/pkgconfig/
npm install keytar
npm i
npm run rebuild
npm run package
./release/linux-unpacked/safe_hosting_manager

#27

Thank you … :slight_smile:
OK - back to where I was a couple of days ago -

Browser compiles OK
Web hosting manager opens but is waiting for Authentication - No authenticator dialog box to Allow/Deny…


#28

That is unfortunate for you.
Maybe something Ubuntu specific, I’ve always had the ‘Allow/Deny’ authenticator dialog box.


#29

I have a Mint bootable USB somewhere - might give that a go and see if it helps…


#30

Are you able to run other safe apps like safe-vfs?
Does the authenticvator dialog box work for them as previously?


#31

No, haven’t looked at it yet. Maybe tomorrow.
fyi: I’m not a web developer, so i’m not that familiar (yet) with npm, node.js etc.


#32

I have same symptoms as @southside, but on Debian.


#33

You and me both pal. Im here under false pretences. I’m really a screwdrivers/hardware kinda guy who just plunges in until I get stuck and shout for help. I am no developer, never taken a single days software course in my puff.

That said, I know enough to know that if @happybeing has the same symptoms on Debian, but it works for you on Mint, then the issue must lie in the tiny differences between the distros.
I imagine Debian as the daddy, Ubuntu as the grown up son with a bit more polish and Mint as the incredibly cool grandson with amazing dress sense.
But until we know exactly what environment was getting used at MaidSafe maybe I am talking mince…
It has been known to happen…

Why does the code to make this dialog box


work on Mint but nit on Debian and Ubuntu. We also know it works on a Mac but I know nothing of these things. Its not a huge sample, I may be barking up the wrong tree but the fact that we seemed to need to install different dependencies may be a clue.
@frabrunelle can you tell is who else was working on this and what distro they were using?

EDIT:
Can @ben @hunterlester @bochaco @Krishna tell us if this could be related to this issue ?


#34

Just to add to the confusion it works for me now on Ubuntu 15.10. Before I was getting stuck at the authentication stage but I wiped everything and followed @draw’s instructions to the letter and it worked. I can’t view my website, but I guess that’s the next chapter.


#35

I’m happy for you. Blows my rather unlikely theory about differences in thee Debian family theory to shreds but thats what theories are for - getting disproven sooner or later.


#36

Yeah, I thought I’d better stick my oar in before you want too far down that particular blind alley!


#37

thank you .
Hopefully one of @frabrunelle @ben @bochaco @Krishna or @hunterlester can let us kno if it could be related to the Safe browser auth request pop-up error issue


#38

Hi @southside, do you think it’s worthy to try out by wiping everything as @JPL did? We did test this with Debian 8.
I guess you are using the correct versions for node and rustc, and make sure you install the dependencies for the web-hosting app. It’s crucial to switch to dev branch right after you clone the repo.


#39

Thank you - its working now after a complete wipe and reinstall.
Still can’t see what I did differently but I get the auth dialog now.
BEd now its past 4am here and I’ll test furthe r in the morning

Thank you


#40

Just tried, and I believe that the browser auth only works with the release version, which means have to do the package. Once I did that, the auth dialog pops up in the browser. Hope that clarifies a bit.


#41

And the same holds true to the accompanied sample apps, eg. safe_hosting_manager, etc. it has to be the released package in order to work properly.