How to build the SAFE Browser and upload a website with Mock-Vault


#62

so i got the browser running but when I try to go to safe-auth://home then nothing pops up… Ubuntu 16.06… ?


#63

Click on the wee grey rocket next to the input box

That will trigger the authorisation dialog Log in or make a new account.
Then the rocket will turn blue.


#64

Yeah did that 9 times before posting, also tried typing it, nothing brought about any new pages or changes at all from the browser


#65

I’ve experienced that before. I think it means the authenticator didn’t compile properly. I remember a few error messages in the readout towards the end of the process.


#66

happen to have a linux compiled version handy? you seem to be the man for that :slight_smile:


#67

As a matter of fact I do…


#68

Has anyone managed to get this running on Windows? When running pack-authenticator it just runs endlessly (I think it just hangs) and I’m not sure if it’s complete or not. If I ctrl+c it, I’m able to compile the browser but when clicking on the rocket nothing happens.


#69

Some of us linux guys are still having bother. Best ask @polpolrene .


#70

Hm, strange. Just tried it on linux and get the same behavior. When looking into the dev tools I see the js error: request to http://localhost:8100/0.5/auth failed, reason: connect ECONNREFUSED 127.0.0.1:8100
when clicking on the rocket sign.

It seems that it’s still trying to connect to a launcher or something. I’ve definitely switched to dev branch.

EDIT:
Out of curiosity downloaded @JPL 's compiled version. Same result. It seems it’s a problem of my system (both windows and the linux VM). :confused: Has anyone experienced this error or has an idea what could be blocking the connection to localhost?


#71

That’s weird. Skype maybe?? (Wild guess). What version of Linux are you using?


#72

Are you using anything listed here http://www.adminsub.net/tcp-udp-port-finder/8100 ???


#73

I try several times to build the Safe Browser on windows. I don`t have problems with the pack-authenticator (Build and finish OK) but the Browser show some errors when rebuild native modules.
As you, I’m able to compile the browser but without response when click the rocket or Enter safe-auth://home in the address bar.


#74

When you click on the icon, do you also get the error I mentioned above (right click, inspect element -> console)?

@JPL I’m using Debian 8. I don’t think it’s related to an app blocking a port, because the error happens on both my Windows (host) and Linux (guest) system.


#75

There are the errors I have when install the dependencies in windows.

and a couple of times this error. Always the doble backslash trying to execute node.exe. I see the same error in Maidsafe’s Appveyor test.

Not in my case.


#76

Has anyone made any more progress on this lately?
I have been busy with other stuff so have not been touching it at all the past day or so.


#77

I think I got to about the same place as you as far as I can tell - managed to create a simple Hello World website and view it, then got lots of error messages trying to make another one.


#78

Yes this is where I got stuck too (Linux)


#79

No need to build the browser and authenticator anymore (although for fun and interest):


#80

Yep - seems to work OK - but because I have no local SAFE content and I cannot get the web_host_manager to work, I have nothing to browse to… :frowning:

EDIT: What do I have to do to make web_hosting_manager work with mock_routing?


#81

Hello,

I’ve tried it yesterday, and uploading/browsing to a simple website worked for me (not gotten to the SAFE api’s).
You do the same like before (e.g. my instructions of 14 days ago), but without the safe_browser part of course.