How to develop for the SAFE Network (draft)


#106

I mean, if you ping http://localhost:<port> will your server actually redirect you to a https connection.


#107

Ah, wait, I’m wrong. This isn’t done on a per protocol basis (enabling), it’s on hostname : https://github.com/joshuef/peruse/blob/master/app/extensions/safe/utils/safeHelpers.js#L22-L25


#108

Hmm, so let’s look at this. Your blank window, if you inspect, has any html? connections etc?


#109

I can see from the server’s Linux console there are no http requests coming from peruse for https://localhost:8443 and so inspecting the HTML there’s nothing loaded.

EDIT: Just tried it with my build and yarn live-dev. There I can see the browser console output for safe: websites, but if I try localhost the tab view is blanked and nothing is output the the browser console.

I’m going to try the official build of peruse (grabbing 0.3.4 now) to see if there’s a problem with my builds. As I mentioned, I had connectivity problems when building so maybe something is messed up. My internet is intermittent here.


#110

Perhaps worthy checking/confirming that your webserver/webservice is reachable using SAFE beaker browser with localhost://p:<port>, just to confirm it’s an issue in Peruse and not in the webserver or host?
I sometimes use this to locally serve basic websites: ruby -run -ehttpd . -p8000


#111

The server works fine with Firefox (and curl - see PM thread I’ve just invited you to).


#112

Just to note here, Safe Browser has the same problem.

It’s looking like certificate trust to me. I’ve been trying to play around with webview settings to get this to work, (https://electronjs.org/docs/api/webview-tag#webpreferences) to no avail as yet.


#113

A little short on time today, is there any documentation on how to run mock with Peruse 0.4.1? @joshuef? Also Bryan and I are charting out new milestones by the end of this week, does 0.4.1 support for streaming using the http range header or is this still up and coming??


#114

This is mentioned in the README, ensure you run yarn with NODE_ENV=dev set, you can then run it in dev mode with yarn dev.

Yes it already does.


#115

Fantastic! Thank you for the quick reply


#116