How to upgrade @maidsafe/safe-node-app


#1

Probably a n00b error but I’m not managing to upgrade @maidsafe/safe-node-app from 0.8.1.

I have done npm upgrade and it reported that it updated some packages, but npm list @maidsafe/safe-node-app still shows 0.8.1.

My package.json shows "@maidsafe/safe-node-app": "^0.8.1", which I think means allow versions 0.8.1 and above, but now I’m stuck.


#2

Been a while for me posting this forum!!

^0.8.1: The caret tells npm not to update to any version greater than 0.8.x. It looks at the left most, non-zero, integer and considers any greater semver upgrade to be “breaking”, forcing you to make sure you want to upgrade. So the semver range for ^0.8.1 is >=0.8.1 && <0.9.0 and ^1.0.4, for example, is >=1.0.4 && <2.0.0.

npm i @maidsafe/safe-node-app@latest will install 0.9.1 for you.


#3

Thanks Hunter, I misunderstood the carat!


#5

This topic was automatically closed after 60 days. New replies are no longer allowed.