Peruse-dev does not want to load properly


#1

First, I’d like to praise @joshuef for the web-hosting-manager-mock release.
I haven’t used it yet, but I really really appreciate it’s existance.

Anyway, I’ve downloaded what I think is the latest linux-x64-dev package (team peruse’s version control is confusing lately), then moved it to /opt/Maidsafe, and ‘chowned’ the directory to root:root.

My problem is that my site appears as empty apart from the title in the tab bar in Peruse while it’s working fine in the beaker browser.
The only error I see from inspect element is the ‘uncaught: …window.eval()’ error.

This is what happens when I start peruse-dev:

[folatt@MyComputer Peruse-dev]$ ./peruse --debug

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
      Started with node env: development
       Log location: /home/rogier/.config/Peruse/log.log
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Running with derived constants:

isRunningDebug? true
shouldStartAsMockFromFlagsOrPackage? true
isRunningUnpacked? undefined
isRunningPackaged? true
inMainProcess? true
startedRunningProduction? false
startedRunningMock? true
isRunningSpectronTestProcess? undefined
isRunningSpectronTestProcessingPackagedApp? undefined

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Main process starting.
App Ready
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Unhandled Rejection. Reason: Cannot find module '../screen'
At: Promise {
  <rejected> { Error: Cannot find module '../screen'
    at Module._resolveFilename (module.js:485:15)
    at Function.Module._resolveFilename (/opt/Maidsafe/Peruse-dev/resources/electron.asar/common/reset-search-paths.js:35:12)
    at Function.Module._load (module.js:437:25)
    at Module.require (module.js:513:17)
    at require (internal/module.js:11:18)
    at Object.get [as screen] (/opt/Maidsafe/Peruse-dev/resources/electron.asar/browser/api/exports/electron.js:11:16)
    at e.exports (/opt/Maidsafe/Peruse-dev/resources/app.asar/main.js:9:306079)
    at f (/opt/Maidsafe/Peruse-dev/resources/app.asar/main.js:9:102876)
    at App.<anonymous> (/opt/Maidsafe/Peruse-dev/resources/app.asar/main.js:1:103918)
    at Generator.next (<anonymous>) code: 'MODULE_NOT_FOUND' } }
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

In case I’m supposed to run peruse-dev as superuser,
I get this when I start Peruse as superuser:

...
Problems starting internal peruse server
Error: listen EADDRINUSE 127.0.0.1:3984
    at Object.exports._errnoException (util.js:1024:11)
    at exports._exceptionWithHostPort (util.js:1047:20)
    at Server.setupListenHandle [as _listen2] (net.js:1319:14)
    at listenInCluster (net.js:1367:12)
    at GetAddrInfoReqWrap.doListen [as callback] (net.js:1493:7)
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:97:10)
errorInWindow Uncaught Error: listen EADDRINUSE 127.0.0.1:3984
Background process renderer loaded.
OnOpen: Setting mock in store.  true
Authenticator lib status:  true
Wrapping Address bar buttons LHS
Triggerin auth URL decode { id: 2980551291,
  uri: 'safe-auth:AAAAAHuap7ECAAAAGwAAAAAAAABuZXQubWFpZHNhZmUucGVydXNlLWJyb3dzZXI' }
Authenticator.js decoding request safe-auth:AAAAAHuap7ECAAAAGwAAAAAAAABuZXQubWFpZHNhZmUucGVydXNlLWJyb3dzZXI
IPC.js: another response being parsed.: { error: null,
  id: 2980551291,
  res: 'safe-bmv0lm1hawrzywzllnblcnvzzs1icm93c2vy:AQAAAHuap7ECAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA',
  type: 'DESKTOP',
  uri: 'safe-auth:AAAAAHuap7ECAAAAGwAAAAAAAABuZXQubWFpZHNhZmUucGVydXNlLWJyb3dzZXI' }
authFromInternalResponse
previousState:  null
Triggerin auth URL decode { id: 2980551291,
  uri: 'safe-auth:AAAAAHuap7ECAAAAGwAAAAAAAABuZXQubWFpZHNhZmUucGVydXNlLWJyb3dzZXI' }
Authenticator.js decoding request safe-auth:AAAAAHuap7ECAAAAGwAAAAAAAABuZXQubWFpZHNhZmUucGVydXNlLWJyb3dzZXI
Error at req processing for: { error: 'Cannot read property \'auth_unregistered_decode_ipc_msg\' of null',
  id: 2980551291,
  res: null,
  type: 'DESKTOP',
  uri: 'safe-auth:AAAAAHuap7ECAAAAGwAAAAAAAABuZXQubWFpZHNhZmUucGVydXNlLWJyb3dzZXI' }
...

This results in the titlebar and perhaps menubar as well missing, unless that’s meant to be, but I don’t think it is.


#2

FYI I haven’t had the title bar and menu since the Peruse WebID release. I’m not sure if it is intended, but it hasn’t mattered.

I haven’t used the Dev build, I either use the release or clone the repo and use yarn (see the repo README.md).


#3

Thanks for the info. That means I’m not alone in this. It matters to me a bit. It’s difficult to drag windows when they don’t have title bars.

I just noticed that the one I’m using the WebID dev release and that the dev release is all that’s needed.
Can you use it without using sudo?
And why doesn’t my site show up?


#4

I’ve never used sudo to run Maidsafe stuff. I don’t know why your website isn’t working sorry - haven’t looked into it.


#5

I just tried it peruse again. It’s working. I don’t why. It’s still the same version.
I have noticed though that peruse does not always shut down properly, so it’s still running even though the window’s gone.
I have yet to figure out what causes that.


#6

This was recently fixed, and the fix was included in the Peruse-WebID POC release, so if you are running Peruse v0.6 is expected until we release v0.7 of Peruse.


#7

This topic was automatically closed after 60 days. New replies are no longer allowed.