Possible bug: two workstations not sharing data

Quote straight from the Dev update thread:

So I’ve been playing around with this thing but I ran into a weird
issue. I have two computers set up, one windows the other ubuntu, when I
upload files (in both public and private directories) I can only see
the files from that computer. SO I uploaded a text file on linux, and
can only see it on linux. Same story on Windows. But both versions show
the same total puts. Does anyone know what’s going on here?

1 Like

Thanks for reporting.

Just to clarify, the problem persist across safe launcher and demo app restarts.

@kagetoki have you tried uploading a file in the public folder and make it available via the dns-service? Does it show up in the beaker browser on both system or only on one?

Yes, this occurs across restarts. The majority of attempts were in private data only. I made one attempt in public data with similar results.

1 Like

Were you able to access it via beaker though (trying to pin down if it is a routing issue or in the demo app)?

Didn’t try to, I just wanted to test the private data function. Here are some screenshots if that helps.

1 Like

Sorry, new users can only post one image at a time.

1 Like

So I published a site on my linux box and the service appeared on the demo app on windows as well. But I was unable to access the site from safeBeaker on either machine for some reason. Kept getting, “This site can’t be reached” ERR_Blocked_BY_client

EDIT: nevermind I can access it I didn’t realize you needed to type Safe:// In the demo app it just say “http://blah

be sure to type the full url including the safe://-protocol, like so: safe://blog.ben :slight_smile:

Edit: Also bumped your status, you shouldn’t have that limit any longer.

1 Like

Thanks. So I can confirm that I can access files in the public directory via safebeaker from the opposite workstation. Probably a bug in the demo app then. However, when I run the demo app on the windows box (the site was published on the linux box) I cannot see any of the files in the public folder. Neither the published service, nor the text file I uploaded.

Edit 2: so when I’m on the windows box (the site was published on the linux box) in the ‘manage websites’ section, I click on ‘Edit Files’ under the service I published on linux and I get ‘Operation Failed\n Failed to fetch Directory \n Reason \n FfiError::PathNotFound’

1 Like

Thanks @kagetoki, that’s very helpful to know. Looks like we have a cross-platform bug in the demo app.

Can you please confirm the versions of the demo app are the same in both machines?

In the latest release the reverse identifier is updated and that results in a new application root directory. Please use demo_app version 0.6.1.

Please do let us know if the problem persists.


Ah, that was it. My apologies. Somehow I grabbed the wrong version of the demo app on linux, 6.0 instead of 6.1. How embarrassing :blush:

1 Like

No worries. Good to know we don’t have a bug! I’ll close this then.