Running Test Network

Hi everyone this is Will right now, but am sharing this account with several of our MaidSafe Asia members, as an official profile.

We are trying to run our own alpha network and using the droplet_deployer on Github. Everything’s working nicely and it’s great to have new tools like this these days. Have come a long way :+1:

It’s very strange though, we keep testing it and it gives different errors at different stages, not following any type of pattern which is unusual. Here are some error codes we get :: 502 :: 442

The biggest one we keep running into is “PERMISSION DENIED” (*see below) and I ran a chmod 777 on all the relevant files and folders but it still pops up sometimes.

Could anyone give any insight into setting up the network please, perhaps even a short Skype call at some point.

We have several ways we will use this network to keep promoting SAFE throughout Asia once we get this running, thank you. Perhaps @hunterlester @bochaco etc

Most common error*:

PS it seems like we might be missing the server image snapshot?

Hey Will and team.

Assuming you guys followed all the previous instructions as discussed on our call & chats, it looks like you are pretty close to completion here as you are at the stage of transferring your safe_vault & associated config files over to your nodes.

The IP that is listed in your screenshot - is that one of the nodes of your network? Or is this a server that you are using to scp the files over to each node?
I wonder if you are able to ssh to that machine using the details it prints on screen? And whether you are able to scp your generated files to the exact location on that machine as the code in your screenshot is trying to do? I assume you’ll be able to narrow down your issue a little by trying this.

If you are able to manually ssh and scp to this machine without any issues then I’d suggest just skipping the automated scp part of the droplet deployer script and write your own quick scp script, even just a quick 'for ip in,; do scp safe_vault qa@$ip:~/; done` would suffice in transferring the files over and unblocking you :slight_smile:
If you would be constantly deploying networks then it would make sense to dig deeper but it sounds like this is more or less a 1 off scp for you guys.


Hi everyone,

I managed to start up the local testnet successfully. Also I’ve downloaded the Safe Browser and copied & renamed the config files over from the safe_vault.

Now I’m wondering if I still need to “Claim an Invitation” (get the Invitation Token) to create an account since I’m connecting to my own local testnet? Is there a way to bypass this token input since I’m running on my own testnet?


You don’t need to claim an invitation. Just enter anything when prompted for the invitation (but not the empty string).

Hi tfa,

I’ve tried that, but it prompted with this error message after entering the Account Password & Confirm Account Password:-

“Core error: Unexpected: Could not connect to the SAFE Network”

By the way, is there a way to check if the Safe Browser is connected to my local testnet successfully?

That can be many things. Did you follow the instructions here, for example do you run at least min_section_size nodes?

Thanks, I’ve got it working already. Just needed to change a few lines in the config files like you said.

By the way, do you know what is the usage of “invite_key” in the safe_vault.vault.config file?

This topic was automatically closed after 60 days. New replies are no longer allowed.