SAFE Drive - help with testing


#62

Bah - not my day :roll_eyes:

user@user1:~/safe-fuse-test/safenetwork-fuse$ node bin.js
module.js:550
    throw err;
    ^

Error: Cannot find module 'debug'

#63

John, you are doing valuable work. These look like bugs too - so that’s actually a win :wink:

It shows I don’t understand it all and/or don’t have time to test all the ways I can mess up. So, again: thank you.

Two things to try, first:

DEBUG=safenetworkjs*,safe-fuse* node bin

I’m curious to know if I don’t see that because I always run with DEBUG, although again it looks to me like the npm install was without NODE_ENV=dev though I know you said you definitely did that.

It would still be a bug though so I’m off to look at the package.json

Anyway, a quick fix might be to then try: npm install debug


#64
user@user1:~/safe-fuse-test/safenetwork-fuse$ DEBUG=safenetworkjs*,safe-fuse* node bin
module.js:550
    throw err;
    ^

Error: Cannot find module 'debug'
    at Function.Module._resolveFilename (module.js:548:15)
    at Function.Module._load (module.js:475:25)
    at Module.require (module.js:597:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/home/user/safe-fuse-test/safenetwork-fuse/bin.js:3:15)
    at Module._compile (module.js:653:30)
    at Object.Module._extensions..js (module.js:664:10)
    at Module.load (module.js:566:32)
    at tryModuleLoad (module.js:506:12)
    at Function.Module._load (module.js:498:3)

#65

Yep, there’s a bug in the safenetworkjs/package.json so high five man :grinning:

So in safenetworkjs, you need to do:

npm install --save debug

#66
user@user1:~/safe-fuse-test/safenetworkjs$ npm install --save debug
+ debug@4.1.0
added 16 packages from 3 contributors, updated 2 packages and audited 331 packages in 2.063s
found 1 high severity vulnerability
  run `npm audit fix` to fix them, or `npm audit` for details

#67

Yeh, that’s not one of ours as we say in the trade :wink:

Thanks for reporting it though. Nothing I can do for now.


#68

No worries. Think I’ll take the lazy option and wait for the zip package!


#69

By all means, although I think you’re probably there now. At least run it! :laughing:

That last scarey message is only a warning. The code works regardless.


#70

OK I tried node bin.js and got the same error - do you reckon it’s worth starting again from scratch? I’ll try the build process again with the extra steps.


#71

I don’t understand why it is complaining about debug if you have just installed it. You could check that the following directories exist:

safenetworkjs/node_modules/debug
safenetwork-fuse/node_modules/debug

I not, then try npm install --save debug in the corresponding project directory and check again.


#72

I’m going to cook dinner now so may not be responsive. Sorry this isn’t going as smoothly as I’d expect. I’ll have to walk through the README.md instructions again.


#73

Yeah they exist OK. Ooo run build-mock seems to be working now. Also off for my dinner!


#74

They exist and you still get this error running node bin?


#75

Aha - node bin rather than node bin.js works. Peruse has now popped up but it’s the live rather than the mock version and the safe drive doesn’t seem to have mounted. I’m going to run through it all again


#76

I’m in! Live version again, I can’t get mock to work. Worth noting that ./mount-safe needs to be run from the safenetwork-fuse/dist/prod folder.


#77

Pretty sure there’s no difference there, so it will be something else.

Cool, so did you build?

node bin runs the code before build. ./mount-safe runs the built version.

Anyway, good to see you have something to play with. :slight_smile:


#78

No, the build failed again. Lots of warnings then it gave up. However, node bin started Peruse and ./mount-safe mounted the drive. It seems pretty much the same as before though (copying a small file into _public causes everything to hang). I did manage to mkdir though. Is that new?


#79

I’m a bit confused as to what’s happening here. If you have a ./safe-fuse, you must have built it. I haven’t tested the build though, so don’t know what works or not when built, but yes mkdir is a new feature. Also try the speedup with the File Manager.

When you do node bin that is the same as running safe-fuse so it is one or the other that mounts the SAFE drive. The first is running the code - unbuilt - the second runs the same code in built form.

So I suggest you just try node bin and if that mounts the drive, play with that and forget about building and mount-safe.


#80

You can only copy to a path that already has files uploaded by WHM. So copying into _public itself won’t work, but copying a file next to where you already have at least one file, say index.html should work.

This is all useful by the way, it’s also helping me think about the UX. I was thinking that copying a file to a new directory in _public could trigger creation of a new container for the file, if that makes any sense? I’d be interested to hear what you think.


#81

node bin starts Peruse but doesn’t mount the safe-drive.

Yes, sorry. I think the build did work. The first time I tried ./mount-safe nothing happened so I tried node bin and then ./mount-safe and that at least did something. However I just did the build again and retried (just in case, so as not to look a fool) and this time the Peruse opened. Right, onwards!

BTW a good tip if it hangs is fusermount -uz ~/SAFE

EDIT: not really working for me I’m afraid. ./mount-safe starts Peruse but doesn’t mount the safe drive. Running it again from a separate terminal mounts the drive but even trying to copy a tiny file via the command line into a pre-existing public folder with files in causes it to hang.