SAFE NodeJS App Tutorial: Button doesn't do anything.


#1

I followed the tutorial, only changing the titles to the app I want to create, so pay no attention to that, and am no longer getting any errors :).

However, for some reason, pressing the “Add a trip to the plan” button doesn’t do anything. What could be the cause of that?

In the link below I have the safenetwork script:


#2

Hi @Folatt! After npm start observe that the authenticator tab would open in your safe_browser / peruse window. You’ll need to login ( if not already logged in) and click Accept to give permissions for your app to send data to the network. I cloned the repo from your GitLab link and it works for me.

Note that once you click Accept in the authenticator there will be two trips displayed by default. Also, if you toggle developer tools in Electron, you’ll get a confirmation message Application connected to the network once the app is ready.


#3

Hi all,

I was playing with this on Monday (for the first time… I know… shocking!)

There were two things I noticed:
i) you have to enter text in the trip field
ii) the connection has to be live (i.e. mock browser up in the background first and the electron app authenticated).

I ran in to ii) a couple of times (most likely cause I was messing around a lot) - closing and restarting certainly solved it each time.

David.


#4

When I click accept, the screen stays white.


#5

Did you try toggling the developers tools in Electron? If there is an error, you should be able to find a stacktrace.


#6

I don’t know why or how, but after closing the browser it works this time.
Perhaps I only clicked on ‘Accept’ before when the app was still compiled incorrectly?

That’s another odd thing. The app only shows when the browser is closed.


#7

UDEMY, this dev team is super stretched thin. Watch 20 dollars worth of udemy courses and what they leave out you can fill in.