Solved: Requested service is not found

Hello, more troubleshooting questions for those more experience.

I have a private test network that allows for account creation, data upload, min_sec_size = 5 and I run 5-8 vaults (I scaled it down to 5 due to some of the same issues mentioned here: Trying to build a global network )

I am able to create public IDs and websites, however they only appear to be available on the original machine I created them on.

One odd thing is that creating two public IDs and sites, I received two different responses in my browser:
“Requested public name is not found”
“Requested service is not found”

I don’t quite understand the DNS model with SAFE, I think I read something about it being like DHT, and I’m guessing that vaults should be managing that info and acting as DNS servers, but I could be a bit off. Could somebody advise me on that? Is there some config I need to add? I’m using fairly default settings and am a bit confused as to why public IDs aren’t accessible on my second browser.

Thanks for the input in advance!

I can’t speak as to why your data isn’t propagating to the rest of your network (as seems to be one issue [@Fraser, perhaps you’d be able to help with debugging that side of a local network?] ), but I can explain what’s going on with the current ‘DNS’ setup.

Your two errors are similar, but distinct.

Essentially a Public Name, is a mutable data saved at the XOR location of the sha3( <public name string>), so when no data is found at that location, you’ll see Requested public name is not found.

The data that should be stored at that location is a map of <service>.<publicName>, such that you can map www.whatever and somethingelse.whatever, and point those to different data on the network.

So Requested service is not found is an error when something-doesnt-exist.whatever, and the something-doesnt-exist entry could not be found.

That’s the ‘current’ implementation. Though we’ve an RFC open that specs out a desired path forward using RDF to clarify the data (as well as describing how public name resolution would work, in general (which is something that’s been missing). You can read that here.

Hope that helps clarify that! (Feedback/thoughts etc are super welcome btw, we’ve a thread dedicated to that.


Thanks, I had posted/edited/deleted my response but looking back it doesn’t actually explain it. I had been running a small test network then built a new/bigger one, between several builds/releases of the browser I made the mistake of loading the wrong one up, so I was really just on the wrong network…oops. But perhaps this will help somebody else in a similar spot, thanks for the input though!


This topic was automatically closed after 60 days. New replies are no longer allowed.