Can anyone build Mock-Routing on Win?

Hey, I just installed this on Windows 10/64 and had no problem.

  • Go to this website and install MinGW. That shouldn’t give any problem.
  • Set your Windows path like the guy is doing here in this video. I directly linked to the right part in the video.

That’s all!

You should be able to check the version from whatever directory you’re in. That’s the reason you’ve been asked for GCC, the script wants to just start GCC and use it. If the path isn’t right the buildscript isn’t able to find that little executable.

Here’s the full video.

let me know if this works.

EDIT: If I remember well you want to use this version of Rust. Here’s the full list of files. Make sure to pick the GNU one :+1:.

2 Likes

ok thx I went there and installed the overall program,

and marked these two and installing them. Those are correct right?

Don’t know for sure, I just installed them all :yum:.

hmm well ok I’ll try installing them all now this time instead

thx guys it’s just their Vietnam meetup is today and I need to help because everyone uses windows. They want to show what SAFE Apps look like and make some new examples

Have you set the path like the dude in the video??? You really need to, no matter what you install.

This is what you need to set in system variables:

1 Like

yep definitely, nothing

that screenshot was what I get after doing all that together

at least I see “gcc.exe” in that “C:/MinGW/bin” folder, which is nice

but still nothing working on cmd “gcc --version”

I had trouble the first time. When you add the line in the path make sure to give an extra “enter”. Then the path to MinGW really gets added. After that choose the OK on all the different forms like you already did.The dude in the video is giving the extra enter as well, if you just choose OK it doesn’t work for some reason.

EDIT: Here’s the exact part in the video.

ok I kind of hacked something together with this:

PATH=C:\MinGW\bin

so once I cd’ed into the folder, I typed that command above and gcc --version works so now I’m trying to compile mock-routing launcher

it only has to work this one time and that’s enough for me to give a binary to everyone :slight_smile:

1 Like

dang dang dang dang dang

GCC working now? So this is new trouble with something :grin:?

I guess, did you ever get it working? build mock-routing launcher successfully?

No, not really tried very hard though as I know a lot of others have trouble as well. I once build my own Vault and the “old” browser without Authenticator. I’ll wait until the devs say: here’s the script, should work now.

I think you are replacing your system path with only the single path entry for gcc. That’s not right, you need to add the mingw dir to your path not replace it.

Start the System Control Panel applet (Start - Settings - Control Panel - System).
Select the Advanced tab.
Click the Environment Variables button.
Under System Variables, select Path, then click Edit.

EDIT - Log in again before doing this as you probably have a screwed path right now :wink:

1 Like

Ok I think I got this sorted, I had the MinGW variable in the user variables part also, before fixing it just now. Also wasn’t clicking the “Path” one before

trying to compile again…

thx very much for the help wit hthis

3 Likes

ugh, IDK it gave me the exact same error again as the black cmd screen i posted above

EDIT: Updated pic above, in previous post^

Hmm now it gave me this new error. Progress! I think

This error message is shorter, so that’s good!

I don’t know what MSVC is

Seems perhaps you chose the msvc build for rust and not the gcc one? If you use gcc it will probably be easier.

Microsoft Visual C.

Microsoft = Visual C tools
GNU = GCC

Rust can handle both, try pick GNU/GCC like David said. It’s in the link I provided earlier. Maybe un-install the old Rust? I remember falling back to that one some time ago.

EDIT:

https://www.rust-lang.org/en-US/other-installers.html#which

great, uninstalled and getting this one

1 Like