Not all code changes seen by Safe Browser in dev mode


#1

Maybe the following problem is already known or I’m doing something wrong.

I’ve built the safe_browser (v 0.6.1) with NODE_ENV=dev on Linux Mint 18.2.
When I change my javascript code (app.js), the Safe browser (sometimes) still uses the old version of the file.
Changes on (localhost://p:8000/)index.html aren’t a problem. At least at the last occurrence of the problem, before I’m not sure.
Other browsers do see the change of the javacript code.
option ‘Hard Reload (Clear Cache)’ in the Safe browser or reboot of the OS doesn’t resolve the problem.
I’ve also tried another webserver: the same result.
Removing the contents of the directory ~/.config/SAFE Browser did solve the problem. So probably some cache in this folder that isn’t updated?


#2

Ah this one slipped past me! Excuse the long delay.

This is very interesting that cache isn’t being updated here.

Looking into it…

This only started with mock browser v0.6.1?
How about with the release of mock v0.7.0?

What was the last version you developed with where you didn’t experience the caching bug?


#3

Hello,

Thank you to look into this!

After that occurence, I haven’t tried again: it was on version v 0.6.1 (self compiled on Linux Mint 18.2).
If I’ve time I could try later to get the same problem with (precompiled) version v0.7.0, if you want.

Concerning the latest version where I didn’t have that problem: I don’t know.
I’ve had a couple of different issues, caused by different things (like my own stupidity), so it took a while to detect/isolate this issue.


#4

This topic was automatically closed after 60 days. New replies are no longer allowed.