SAFE Browser issue

I’m a C# programmer, how can I get started?

How can I resolve this issue in SAFE Browser:

The SAFE Browser was not able to connected the network.

Hi @EurekaChen,

Could you please give a bit more information? (e.g. what version of the SAFE Browser you are trying to run, which operating system you are using)


SAFE Browser version: v0.15.4-beta2
on Windows 10 version 10.0.18362.535

I don’t know how to start SAFE Network App and SAFE Browser. How can I connect to the network?
Thank you!

Right now, you have two choices, you can connect to the Shared Vault or run your own Vault.

To connect to the Shared Vault Network:

  1. Download the vault_connection_info.config shared vault config file from GitHub

  2. If you are on Windows save this file to C:\Users\<USERNAME>\AppData\Roaming\MaidSafe\safe_vault\config\

To run your own Vault:

  1. Download the latest Vault release:

  2. Run $ safe_vault

See this topic for more info:

Thank you very much :grinning:
I ran the safe cli cmd in Windows 10 with administrator:
safe auth install
I get this error:

[2020-01-20T06:18:25Z ERROR safe] safe-cli error: [Error] AuthdClientError - Failed to execute authd from 'target\release\safe-authd.exe': 系统找不到指定的文件。 (os error 2)

I tried to run safe-authd
safe-authd start
It returns:

Starting SAFE Authenticator service (safe-authd) from command line...
[2020-01-20T06:21:12Z ERROR safe_authd] safe-authd error: [Error] GeneralError - Failed to start safe-authd service: [SC] StartService: OpenService ʧ�� 1060:


Hi @EurekaChen, the problem you have in installing authd seems to be that you are not specifying the path to where the safe-authd.exe is located, where did you download the safe-auth.exe to?

You’ll need this command to put it in the path:

set PATH=%PATH%;<safe-authd.exe path>

and then it should work fine doing safe auth install from the same console.

Thanks! It’ seems work when using Shared Vault Network, but all with UNKNOWN PUBLIC NAME.
I noreg

If i want run my own Valut, I get prompt “Waiting for connections …”
and SAFE browser back me with “The SAFE Browser was not able to connected the network.”

I found the problem: When I shutdown the firewall, it does work.
But which tcp port should I allow pass and SAFE Browser can work properly?

This topic was automatically closed after 60 days. New replies are no longer allowed.