Safe web Api Playground suddenly refuses to start


#1

Hi !

continuing my exploration on how to build safe sites…

While it worked nicely until last hour, safe_web_api_playground now refuses to start with the following :

https://pastebin.com/NRWrSDQM

I tried to checkout the repo , erased my MockVault file, updated node and npm,


#2

It was working until the last hour? :laughing:
Okay, let’s narrow this down together.

I see that you are using node v8.5.0
I installed 8.5.0, deleted my node_modules, installed again, and was able to run, so node and npm versions seem to be fine.

Any notable changes on your system within the last hour from when the error occured?
Will you paste the output from your command line, in addition to the npm-debug.log that you provided pastebin?


#3

well I don’t think I changed anything when it stopped working.
After that I updated node and npm , with the hope it would solve the issue.

so, my console says :

[d2r2@nestor safe_web_api_playground]$ npm run gulp

safe_web_api_playground@1.0.0 gulp /home/d2r2/archives/maidsafe/git/safe_examples/safe_web_api_playground
gulp

[20:01:24] Using gulpfile ~/archives/maidsafe/git/safe_examples/safe_web_api_playground/gulpfile.js
[20:01:24] Starting ‘js-deps’…
[20:01:24] Finished ‘js-deps’ after 16 ms
[20:01:24] Starting ‘html’…
[20:01:24] Finished ‘html’ after 1.25 ms
[20:01:24] Starting ‘css’…
[20:01:24] Finished ‘css’ after 794 μs
[20:01:24] Starting ‘css-deps’…
[20:01:24] Finished ‘css-deps’ after 1.04 ms
[20:01:24] Starting ‘js’…
[20:01:24] Starting ‘watch’…
[20:01:24] Finished ‘watch’ after 14 ms
[20:01:24] Starting ‘serve’…
[20:01:24] Finished ‘serve’ after 54 ms
[20:01:24] Starting ‘fonts’…
[20:01:24] Finished ‘fonts’ after 2.57 ms
[20:01:24] Starting ‘image’…
[20:01:24] Finished ‘image’ after 2.5 ms
events.js:182
throw er; // Unhandled ‘error’ event
^

Error: watch /home/d2r2/archives/maidsafe/git/safe_examples/safe_web_api_playground/static/js ENOSPC
at _errnoException (util.js:1026:11)
at FSWatcher.start (fs.js:1383:19)
at Object.fs.watch (fs.js:1409:11)
at createFsWatchInstance (/home/d2r2/archives/maidsafe/git/safe_examples/safe_web_api_playground/node_modules/chokidar/lib/nodefs-handler.js:37:15)
at setFsWatchListener (/home/d2r2/archives/maidsafe/git/safe_examples/safe_web_api_playground/node_modules/chokidar/lib/nodefs-handler.js:80:15)
at FSWatcher.NodeFsHandler._watchWithNodeFs (/home/d2r2/archives/maidsafe/git/safe_examples/safe_web_api_playground/node_modules/chokidar/lib/nodefs-handler.js:228:14)
at FSWatcher.NodeFsHandler._handleDir (/home/d2r2/archives/maidsafe/git/safe_examples/safe_web_api_playground/node_modules/chokidar/lib/nodefs-handler.js:407:19)
at FSWatcher. (/home/d2r2/archives/maidsafe/git/safe_examples/safe_web_api_playground/node_modules/chokidar/lib/nodefs-handler.js:455:19)
at FSWatcher. (/home/d2r2/archives/maidsafe/git/safe_examples/safe_web_api_playground/node_modules/chokidar/lib/nodefs-handler.js:460:16)
at FSReqWrap.oncomplete (fs.js:154:5)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! safe_web_api_playground@1.0.0 gulp: gulp
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the safe_web_api_playground@1.0.0 gulp script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/d2r2/.npm/_logs/2017-09-26T18_01_24_442Z-debug.log


#4

The watcher may be trying to bind to too many files. I may need to add node_modules to be ignored.

I’ll push an update here in a few seconds…
While we wait for PR to be approved, in your gulpfile.js, add 'node_modules' to this array: https://github.com/maidsafe/safe_examples/blob/master/safe_web_api_playground/gulpfile.js#L87

Then see what happens when you npm run gulp

UPDATE:
I’ll be surprised if that doesn’t fix it. On my end, gulp starts up quickly now when nodemon ignores node_modules.


#5

thank you for your help and patience !..

unfortunately adding node_modules :

ignore: ['build/**/*.*', 'static/**/*.*', 'node_modules'],

seems not to change anything my side.

I tried to reinstall everything from scratch, too, with no avail. Do you know if there is some sort of cache somewhere for npm, and for safe related stuff ?

I really do not understand how it may not work when I delete the whole folder and git clone again.


#6

I should have mentioned. One of those links I posted has commentary about clearing out your tmp folder or whatever nodemon might be using on your system to watch files.

It’s strange that it doesn’t clean up after itself.

Check out some of those commands to clear your system. I’ll take a look tomorrow when I’m back at my computer.


#7

Good morning and thank you very much ! You guys have a really great support at Maidsafe

So clearing /tmp and rebooting fixed the issue - I had not actually parsed the links you sent, sorry about that.
I can go on exploring mutations :smiley: woooop :!

Still I wonder why it went full like that.


#8

This topic was automatically closed after 60 days. New replies are no longer allowed.